Help Portal

Twitch is always live—except for when it's not.

See which areas of Twitch are thriving or having a bit of a rough day below.

Need assistance?


Contact us with any questions or concerns, or follow @TwitchSupport for updates

Resolved Service Impact
Incident Report for Twitch
Resolved
We have received reports of impacted services. This could manifest in chat not working, login difficulties, search impaired, etc. We're looking into the issue.
🛠 We have resolved all known negative service impacts.
Posted Oct 28, 2022 - 16:30 UTC