Help Portal

Twitch is always live—except for when it's not.

See which areas of Twitch are thriving or having a bit of a rough day below.

Need assistance?


Contact us with any questions or concerns, or follow @TwitchSupport for updates

OCE Service Negatively Impacted
Incident Report for Twitch
Resolved
This incident has been resolved.
Posted Sep 14, 2022 - 13:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2022 - 12:38 UTC
Identified
We have received reports of impacted service in Oceania. This could manifest in video not loading, search impaired, etc. We're looking into the issue.
Posted Sep 14, 2022 - 11:41 UTC
This incident affected: Login, Web, Chat, Video (Watching), Video (Broadcasting), and Purchases.