Help Portal

Twitch is always live—except for when it's not.

See which areas of Twitch are thriving or having a bit of a rough day below.

Need assistance?


Contact us with any questions or concerns, or follow @TwitchSupport for updates

Service Negatively Impacted
Incident Report for Twitch
Resolved
This incident has been resolved.
Posted Jan 03, 2023 - 19:23 UTC
Investigating
We have received reports of impacted services. This could manifest in chat not working, login difficulties, search impaired, etc. We're looking into the issue.
Posted Jan 03, 2023 - 18:44 UTC
This incident affected: Login, Web, Video (Watching), and Video (Broadcasting).