Help Portal

Twitch is always live—except for when it's not.

See which areas of Twitch are thriving or having a bit of a rough day below.

Need assistance?


Contact us with any questions or concerns, or follow @TwitchSupport for updates

Resolved Service Impact
Incident Report for Twitch
Resolved
🛠 We have resolved all known negative service impacts.
Posted Aug 30, 2024 - 10:30 UTC