Help Portal

Twitch is always live—except for when it's not.

See which areas of Twitch are thriving or having a bit of a rough day below.

Need assistance?


Contact us with any questions or concerns, or follow @TwitchSupport for updates

Identified Video (Broadcasting) Issues
Incident Report for Twitch
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 23:19 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2022 - 21:17 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 28, 2022 - 20:51 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 28, 2022 - 19:46 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 28, 2022 - 17:33 UTC
Update
🛠 We have identified an issue preventing people from broadcasting on Twitch, and users to be unable to make purchases or Cheer with Bits. We're currently working to resolve this issue.
Posted Sep 28, 2022 - 17:25 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 28, 2022 - 17:08 UTC
Identified
🛠 We have identified an issue preventing people from broadcasting on Twitch. We're currently working to resolve this issue.
Posted Sep 28, 2022 - 17:06 UTC
This incident affected: Video (Broadcasting) and Purchases.